さんまがおいしい季節だねー(´・ω・`)

iGoogle ガジェットの gadgets.flash.embedFlash が動かない件について

Flash,Google — タグ: , — さくら @ 2009/04/10 0:11

さくらです♪こんばんわ☆ミ

iGoogle ガジェットのマニュアルの Flash に関する説明を読むと、gadgets.flash.embedFlash って関数が使えるって書いてあるわ…
でもこんなの大嘘よ!!

…って書くと語弊があるわね。

OpenSocial containers じゃないと gadgets.flash.embedFlash って関数は使えないって言うのが正確だわ。なんとなく Google をうっとおしく感じるのは、このことが日本語のマニュアルのどこに書いてるのか分からないことね。

英語のマニュアルだと、Legacy Gadgets API Developer’s Guide に書いてあるわ。ちなみにこのマニュアルの日本語版は無いっぽいわよ。

This is the legacy gadgets API Developers Guide. It describes the original gadgets API based on the _IG_… namespace. This is the API you must use if you are developing gadgets for environments that don’t support the “renamespaced” gadgets.* API, which currently only works in OpenSocial containers. To develop gadgets for containers that support the OpenSocial API, use the gadgets.* API.

適当に訳すと…

これはレガシーガジェット API 開発者向けマニュアルよ!
このマニュアルでは、前からあった _IG_ で始まるガジェット API を説明してるわ!!
これらの API は、gadgets.* API がサポートされてないときだけ使用すること。ちなみに gadgets.* API は OpenSocial コンテナでしかサポートしてないわよ。
もし OpenSocial に対応したガジェットを作るなら、gadgets.* API を使いなさい!
これってマストよ!!!!

って感じね。
単なる iGoogle ガジェットには gadgets.* API は使えないから、_IG_ API を使えってことね。

ところでどなたか…
OpenSocial API 使ったアプリってどこにあるか教えてくださらないかしら?
簡単なモノで構わないんですけど、見たこともないモノを作ろうと思わなくってよ!!

さくら

1件のコメント »

  1. My family members always say that I am killing my time here at net, but I know I am
    getting familiarity daily by reading such fastidious articles.

    コメント by luciano barbera navy sweater — 2015 年 3 月 25 日 @ 13:09

この投稿へのコメントの RSS フィード。 TrackBack URI

コメントする

Copyright © 2017 さくらたんどっとびーず | powered by WordPress with Barecity